PHP is among the most widely used curly-brace programming languages. It is rather popular because it is free software, which you can use to create interactive websites like community sites, online shopping portals or e-teaching sites as opposed to static HTML sites. A PHP module must be present on the server where a PHP website is hosted so that its code can be ‘translated’. As there aren’t any license taxes for this sort of module and the language itself provides limitless options for the applications that you create, there are hundreds of millions of PHP websites. Moreover, there’re a huge number of PHP-based scripts, which you can use for your websites without needing to have any programming skills. Given the fact that there are a handful of PHP versions, you must make certain that the very same version that you used while building your site is available on the web server as well.

PHP 4 and PHP 5 Support in Shared Hosting

With our Linux shared hosting, you will be able to choose which version of PHP will be active for your shared hosting account, since multiple versions are installed on our servers. With just one mouse click, you’ll be able to switch between PHP 4, 5.2, 5.3, 5.4 and 5.5 and each time a new version is unveiled in the future, we will include it in the Hepsia hosting Control Panel without removing the previous ones. In this way, you will be able to host all the sites that you’ve built over the years. Unlike a lot of other hosting vendors, we will not force you to update such websites, because a script may be out of date, but this does not necessarily mean that it is insecure as you may have implemented modifications to its code to fill safety breaches. For your convenience, you will even be able to choose a different PHP version for each single website that you host in your account.

PHP 4 and PHP 5 Support in Semi-dedicated Hosting

In case you’ve got a website built with an earlier PHP version and you’ve committed time and effort to developing it, fixing safety gaps and inputting web content, you’ll need a hosting service that can support it, since the vast majority of web hosting vendors these days offer only the most recently unveiled version of PHP and abandon the previous versions. We, on the other hand, have decided to permit you to pick the exact version that your very own websites need. Our Linux semi-dedicated hosting support PHP 4 and multiple versions of PHP 5, which goes to say that you’ll be able to run both newer and older scripts without forfeiting any manual tweaks or misspending time and energy striving to make your websites compatible with the web hosting environment. You can change the current version from the Hepsia hosting Control Panel and such a change will apply to the whole semi-dedicated server account, but you’ll also be able to specify a different PHP version for each individual website hosted in your account using an .htaccess config file.